Geolog 6.6
Geolog Basics Tutorial
Contents

Introduction to the Geolog Basics Tutorial .................................................. 1
  Prerequisites ................................................................................................. 1
  Document Conventions ................................................................. 1
  Tutorial Data ............................................................................................. 1
Geolog Overview ............................................................................................ 2
Geolog Workflow ............................................................................................ 3
Release and Project Directories ..................................................................... 4
  Project Structure ......................................................................................... 4
  Directory Structure .................................................................................... 4
The Mouse and Keyboard in Geolog ............................................................... 7
  Mouse Conventions ................................................................................... 7
  Keyboard Support ...................................................................................... 8
Starting Geolog ............................................................................................... 9
Working with Applications and Document Views ........................................... 15
  Methods for Starting Applications ......................................................... 15
  Opening Document Views ...................................................................... 16
  Saving Your Workspace ........................................................................ 21
  Icons and Tool Tips .............................................................................. 22
  Closing Document Views ....................................................................... 24
  Closing Applications ............................................................................. 26
  Closing Geolog ....................................................................................... 26
Using Geolog .................................................................................................. 27
  Working with Multiple Document Views .................................................. 27
  Menu List .................................................................................................. 36
  Properties Dialog Box .......................................................................... 39
  Appearance Palette .................................................................................. 42
Help ............................................................................................................... 46
  Accessing Online Help .......................................................................... 46
  Searching All Geolog Online Help ........................................................ 50
Project Management ..................................................................................... 58
  Project File Structure .......................................................................... 58
  Creating New Projects ........................................................................ 59
  Opening Projects ................................................................................... 61
  Removing / Changing Projects ............................................................ 64
  Deregistering Projects ........................................................................ 65
Introduction to the Geolog Basics Tutorial

Welcome to the Geolog Basics tutorial.

This tutorial is designed for new users of Paradigm’s Geolog product. It teaches you the basics of using Geolog by guiding you, step by step, through a typical workflow and procedures to:

- start Geolog
- open Geolog applications (e.g., Artist, Project) and then open multiple documents within the applications
- use the menus, tool bars and other functions common throughout Geolog
- obtain further assistance via Geolog’s online help, and
- manage your working projects

Prerequisites

A familiarity with computers is an advantage although not essential.

Document Conventions

In this document, all INPUT to the computer is in **Bold Courier New**, while all OUTPUT from the computer is in *Courier New*, but not **bold**.

Tutorial Data

The following additional files (i.e., files not supplied with software) are used in this tutorial:

<table>
<thead>
<tr>
<th>DATA:</th>
<th>stars_master.unl</th>
<th>REPORTS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>LAYOUTS:</td>
<td><em>(Copy from layouts_units)</em> exercise.layout</td>
<td>SECTIONS:</td>
</tr>
<tr>
<td>LOGLAN:</td>
<td></td>
<td>SPECS:</td>
</tr>
<tr>
<td>PLOTS:</td>
<td>All (from Stars project)</td>
<td>WELLS: electra</td>
</tr>
</tbody>
</table>
Geolog Overview

Geolog is used by thousands of oil and gas professionals throughout the world. Geolog has a long history of development guided by user feedback, which has led to a robust, easy to use product. This is backed by a worldwide support network.

The Geolog system stores and processes wellbore data, incorporating advanced graphical displays and analysis techniques from geological modeling to petrophysical interpretation. Geolog's modular design provides for flexible construction of a software environment to suit user needs.

Geolog uses the CORBA (Common Object Request Broker Architecture) client server architecture for fast application and implementation. This allows the Geolog user to concentrate on the application without the need to be concerned with database issues. It also facilitates an easy exchange of geological and geophysical data with other vendors' software products.

Geolog features include:

- Support for a wide variety of industry standard contractor log formats, including DLIS.
- Map based project management.
- Multi-zone, multi-well processing.
- Interactive graphical log display, manipulation and editing.
- Petrophysics, geophysics and statistical analysis.
- Model and interpret log data in highly deviated or horizontal wells.
- Predict logs and predict / propagate facies using various methods.
- Cross-section building and interpretation.
- Geological data and image analysis.
- Integration of vector and image graphics.
- Multiple programming options (e.g. Loglan, Tcl/Tk, Logs Library, gglib).
- Multiple Document Interface (MDI) where multiple document views can be opened within an application.
- Menu List enabling quick access to application menu options.
To Open Move / Copy To
Raw Data:
field logs
lab results (core analysis)
geo. tops & picks
images
lithology
fluid analysis
pressure results
tests

Digitized Data:
tape data

Standardize during load:
names (wells, sets, logs)
units
mnemonics
control of input
index

QC
visualize with layout
consistency of logs
edits
merges
depth match
calibrate
environmental corrections

catalog
archive
duplicate for:
- corporate database
- private database
- asset database

Petrophysics
Geology
Geophysics
Logian

edit
tops
picks
interpret

planned & actual wells

standard formats
ASCII defined
Release and Project Directories

Project Structure

There are 3 types of projects in Geolog:

- **Geolog6** - distributed with the software
- **Site** - your site or organization specific environment
- **Working** projects

Geolog6 and Site

Geolog6 and Site are fixed project names. The installed software resides in the Geolog6 project. This is also referred to as the Geolog home directory and its path is defined by the environment variable GEOLOG6_HOME.

By default, the Site project resides parallel to the installed software directory (e.g., `${GEOLOG6_HOME}/../site`). A Site should be set up when Geolog is installed to contain generic tape names, plotter names, plots, layouts, etc. that are used throughout an organization.

The path to Site is defined by the environment variable MINSITE.

Working Projects

Working projects are used to carry out log analysis. The working project name is also the directory name. Names of basins, fields, sub-basins or authority permits are typically used as names for working projects. A working project directory contains well data, plots, reports, specific log layouts, specifications relating to wells in the database, etc.

When a working project is created, Geolog immediately creates some sub-directories required by the project (e.g., wells). Other directories are created by Geolog (e.g., functions) as and when required.

Directory Structure

All Geolog projects may contain any one of the directories shown in Figure 1, but in general, GEOLOG6_HOME project contains the software and support files for the application. The Site project contains any support files which have been modified from the standard installed files, plus site specific information (e.g., device drivers for tape drives, standard layouts).
Note: The above diagram is also applicable to Windows with the exception that "usr" is replaced with the directory name where Geolog is installed.
<table>
<thead>
<tr>
<th>Directory</th>
<th>Location (R = Release, S = Site, P = Working Project)</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>/app-defaults</td>
<td>R,S,P</td>
<td>Files which control the application’s appearance and behavior. Includes resource files, menus and icons.</td>
</tr>
<tr>
<td>/bin</td>
<td>R,S,P</td>
<td>Executable software modules and shell scripts.</td>
</tr>
<tr>
<td>/data</td>
<td>R,S,P</td>
<td>Log data to be loaded and unloaded by Geolog and tape drive device names.</td>
</tr>
<tr>
<td>/doc</td>
<td>R</td>
<td>User manuals in PDF format. Example scripts, SMR forms, etc.</td>
</tr>
<tr>
<td>/functions</td>
<td>R,S,P</td>
<td>Charts, curves, etc. used for crossplot analysis, macros.</td>
</tr>
<tr>
<td>/graphics</td>
<td>R,S,P</td>
<td>Files for controlling the format of graphic displays: fill and marker patterns, font files, digitizer setup files.</td>
</tr>
<tr>
<td>/imperial</td>
<td>R</td>
<td>Imperial unit layouts, specs.</td>
</tr>
<tr>
<td>/include</td>
<td>R</td>
<td>Source code header files.</td>
</tr>
<tr>
<td>/install</td>
<td>R</td>
<td>Geolog installation files; database server templates, definition files; PNS installation files, etc.</td>
</tr>
<tr>
<td>/layouts</td>
<td>S,P</td>
<td>Layout, Xplot Image3D, Text, and Frequency specification files.</td>
</tr>
<tr>
<td>/lib</td>
<td>R</td>
<td>Library files.</td>
</tr>
<tr>
<td>/loglan</td>
<td>R,S,P</td>
<td>Loglan source code, info files and executables.</td>
</tr>
<tr>
<td>/man</td>
<td>R</td>
<td>Entries for the Unix online man pages.</td>
</tr>
<tr>
<td>/metric</td>
<td>R</td>
<td>Metric unit layouts, specs.</td>
</tr>
<tr>
<td>/mixed</td>
<td>R</td>
<td>Mixed unit layouts, specs.</td>
</tr>
<tr>
<td>/motif</td>
<td>R</td>
<td>Used to map keystrokes to code.</td>
</tr>
<tr>
<td>/plots</td>
<td>R,S,P</td>
<td>Standard header CGM files, example CGM files and digitizer menus.</td>
</tr>
<tr>
<td>/reports</td>
<td>R,S,P</td>
<td>Report files generated by Geolog; printer driver scripts.</td>
</tr>
<tr>
<td>/sections</td>
<td>S,P</td>
<td>Section specification files.</td>
</tr>
<tr>
<td>/specs</td>
<td>R,S,P</td>
<td>Files which tailor the application so that it understands log mnemonics, units, etc. Templates for loading and unloading well data, well map formats, etc.</td>
</tr>
<tr>
<td>/wells</td>
<td>P</td>
<td>Database directory containing well data which has been loaded into Geolog.</td>
</tr>
</tbody>
</table>
The Mouse and Keyboard in Geolog

Mouse Conventions

As with most software, Geolog commands are executed using a mouse.

LEFT button Is to select an object or menu item.
MIDDLE button Is used to move, alter or resize the selected object.
RIGHT button Activates menus associated with the function and selected item.

<table>
<thead>
<tr>
<th>WHEN YOU READ:</th>
<th>DO THIS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Point to something, then quickly press and release the LEFT button (may also be displayed as &quot;click with the left mouse button&quot;).</td>
</tr>
<tr>
<td>Right click</td>
<td>Click using the RIGHT mouse button (may also be displayed as &quot;click with the right mouse button&quot;).</td>
</tr>
<tr>
<td>Middle click</td>
<td>Click using the MIDDLE mouse button.</td>
</tr>
<tr>
<td>Double click</td>
<td>Click the LEFT mouse button twice in rapid succession.</td>
</tr>
<tr>
<td>Drag</td>
<td>Press and hold the LEFT mouse button down while you move the mouse.</td>
</tr>
<tr>
<td>Point</td>
<td>Move the mouse until the mouse pointer on the screen rests on the required item.</td>
</tr>
</tbody>
</table>
Keyboard Support

Geolog supports keyboard navigation. Throughout the training documentation, mouse and menu selection instructions are provided. The documentation does not cover using the keyboard in detail but you are quite welcome to use the keyboard shortcuts, if you so desire. Following is a brief overview.

Keyboard shortcuts are listed, where applicable, next to menu selections and on Tool Tips (see Exercise 4 on Page 22 for an explanation of Tool Tips).

To use keyboard shortcuts:

To display menus: press ALT+underlined letter of menu name

To execute a menu item: press CTRL+letter as displayed next to the menu item (e.g., CTRL+S to save a document)

Further information can be found in Geolog's "Using Geolog" online help documentation.
Step 1: Starting Geolog

Procedure

In this step, you:

- Start Geolog and open an existing working project.

**Exercise 1**

1. Start Geolog as follows:

<table>
<thead>
<tr>
<th>OPERATING SYSTEM</th>
<th>ACTIONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Change directory to the project directory, if required.</td>
</tr>
<tr>
<td></td>
<td>• Enter geolog6</td>
</tr>
<tr>
<td></td>
<td>OR</td>
</tr>
<tr>
<td></td>
<td>Enter the full path to the Geolog6 startup script; for example:</td>
</tr>
<tr>
<td></td>
<td>% &lt;geolog6&gt;/bin/geolog6</td>
</tr>
<tr>
<td></td>
<td>(where &lt;geolog6&gt; is the directory in which the Geolog software has been installed)</td>
</tr>
<tr>
<td>Windows</td>
<td>Click Start &gt; All Programs &gt; Geolog6 &gt; Geolog6</td>
</tr>
<tr>
<td></td>
<td>(assuming the defaults have been used during installation).</td>
</tr>
</tbody>
</table>

A Startup screen is displayed followed by the Project Select dialog box (see Figure 2 on Page 10).

**Note:** When you are more familiar with Geolog, you may start Geolog in a Project directory, in which case the Project Select dialog box is not displayed.
2. Find the **STARS** project using the scroll bar (see Figure 2) in the Projects field.

3. Click on **STARS** and then click **OK**, to open the project and display the Geolog Launcher Bar (see Figure 3 on Page 11).

Instead of selecting the project and then clicking **OK**, you can double click the project name.

Creating and opening projects is discussed in further detail in "Project Management" on Page 58.
### About the Geolog Launcher Bar

Following is a brief description of each of the applications displayed on the Launcher Bar. Each application is covered in detail in separate tutorials.

<table>
<thead>
<tr>
<th>APPLICATION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| **Project** | Manage your working project, and edit and manipulate multiwell data:  
  - Create a map view of all the wells in the currently open project, or a subset of specified wells and/or sections by specifying wells/sections to process.  
  - The wells are located according to the x_location and y_location (latitude and longitude) values stored in the well headers. (The view is dependent on whether the Geographic or Cartesian system is used.)  
  - Import and post contour maps from mapping applications onto your project map.  
  - Use the Z-posting utility to post values of selected logs / constants at well locations on a map, and the Z-Color utility to produce a color grid of those values.  
  - Create multiple views (maps)—each view is saved to a map specification file. Deviated well paths are displayed in either "stick" or "spider" format.  
  - Catalogue views provide tools to search for and view specific data in table format.  
  - Open a Well Catalogue view to batch edit well data.  
  - Multiple document views, for example, a text view, a crossplot and a mapsheet can be open on the screen simultaneously to simplify data management.  
  - Multiwell processing is performed in Project using the Module Launcher. A "module" is a program such as a log analysis program to compute shale volume, or a command for computation, such as TVD (true vertical depth) from a directional survey.  
  - Create cross sections graphically by clicking with the mouse to define a "polyline". Wells can be snapped or projected onto the line of section with user control of the projection angle. |
<table>
<thead>
<tr>
<th>APPLICATION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| Well        | Display, edit and manipulate single or multiwell data.  
• Well data management—display and edit data both graphically and in text form.  
Create and manage layouts.  
• Layouts are saved as ASCII specification files separate from the well data. They are then re-usable templates, easily changed or fine tuned, or standardized and accessible on an intra-company level.  
• Generate and save multi-track layouts for simple to complex presentations.  
| Wellpath    | Create and display graphical plan and sectional views of the wellpath.  
• Calculate TVD, TVT, TST and a vertical section (VS) if applicable data is available.  
• Display drilling targets.  
Display wellbore geometry and image logs in 3D.  
| Facimage    | Build electrofacies models using various methods such as MRGC, SOM, Dynamic Clustering and AHC.  
• Display and interact with electrofacies models using a graphical interface.  
• Apply electrofacies models to log data.  
• Predict logs.  
• Determine the similarity of application data to training data.  
Multiple document views for example, a text view, a crossplot and a layout can be open on the screen simultaneously to view the data in various formats. Manipulation tools for well processing. Object-oriented graphics are employed in well.  
| Section     | Create, display and maintain multiwell cross sections.  
• Each section is saved to a specification file in the project, and the correlation data is stored within the well database.  
• Cross sections can be created in Section as well as in Project.  
• Display wells either vertically or in deviated well format.  
• Define well-to-well correlations interactively by inserting horizons, correlations or formation tops. The depths, as intersected at each well, are stored as a user defined set, for example "Tops" set, in each well. Existing Tops or Formation data can be displayed graphically i.e., auto-correlations, and the actual formation top depths in each well can be edited interactively, with the new positions written back to the wells.  
• Define the correct geologic line style for the correlation lines for example, an unconformable surface, using tools available within the application.  
• Draw faults, and adjust correlation lines up and down along the fault.  
• Display colors and/or lithology fill styles (e.g., sandstone pattern fills) for each defined interval (segment). These can then be stored for future reference.  

www.fanarco.net
<table>
<thead>
<tr>
<th>APPLICATION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| **Geosteer** | Perform geological steering of the well by determining the stratigraphic position inside the earth model.  
• View the planned wellpaths on a horizon cross section.  
• Display a log property cross section.  
• Display 3D targets and formation dip.  
• Edit the horizon cross section.  
• Model the expected log responses based on the wellpath, cross section, and log properties.  
• Model synthetic wellbore images. |
| **Connect** | Loading and unloading data from, to and between working projects.  
• Data can be read from magnetic tape or file.  
• The load/unload facilities within Connect automatically detects the format of the incoming/outgoing data.  
• Data link can be tied to external databases (e.g., Geoshare and OpenWorks).  
• Formats supported:  
  Binary formats such as LIS, BIT, and DLIS can be loaded/unloaded.  
  ASCII formats such as LAS, **Geolog** ASCII, and columnar ASCII files can be loaded/unloaded.  
• Energy saving - Flat ASCII file load/unload specifications define the format of columnar ASCII files. The ASCII specifications are saved to make them "re-usable" for loading other ASCII files of the same format. |
| **Artist** | Create graphic images, or montages by importing multiple graphic files, for use in Geolog applications. These can be consistently prepared, according to an internal company standard, for management and partner presentations.  
• Draw objects such as text, shapes and lines to create an image or enhance a montage.  
• Filters are available for importing and exporting a variety of graphic file formats. Some of the file formats supported in Artist include:  
  ART (Geolog5 Artist dump)  
  BMP (Windows bitmap)  
  CGM (computer graphics metafiles)  
  GIF (CompuServe’s Graphic Image File)  
  TIFF (Tagged Image File Format)  
  JPEG (Joint Photographic Experts Group)  
• Graphics are imported as a "grouped" object but can be "ungrouped" so that their individual graphic elements can be edited. For example, an existing Petrosys map title block can be imported into Artist and ungrouped, allowing you to alter every aspect of the title block. |
<table>
<thead>
<tr>
<th>APPLICATION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| Loglan      | Loglan (an acronym for *Logging Language*) is Geolog’s log processing language and provides a Software Development Kit for Geolog.  
  - Write programs in Loglan to develop modules for log processing and database access.  
  - Modules are fully integrated into the **Geolog6** environment and function in exactly the same way as any other module in **Geolog6**. |
Step 2: Working with Applications and Document Views

Procedure

In this step, the various methods for starting Geolog applications, opening multiple document views, and then closing the views and applications are explained. You will learn how to:

• Start applications
• Open multiple document views (windows) using the menus
• Open multiple document views using icons and tool tips
• Save a workspace for future retrieval
• Close document views
• Exit applications

Exercise 1

In this exercise, you will open two applications using two different methods.

Methods for Starting Applications

Via an Application Button

1. On the Geolog Launcher Bar (see Figure 4), click on the Artist button to open the Artist application window.

Via Pulldown Menus

In the Geolog tutorials when you see an instruction such as:

Applications > Project...

This is a prompt for you to select an application from the Menu bar of the currently open window.
In this example, you click with the left mouse button to select the menu item "Applications" and then select the "Project..." option from the list displayed (see Figure 4).

1. Select **Applications > Project...** to open the Project application window.

![Figure 4: Using pulldown menus](www.fanarco.net)

All applications initially display a blank screen. You then specify the data to display, create a new file, and/or open existing files or views to display the data.

**Exercise 2**

In this exercise, the menus are used to illustrate opening multiple document views.

Using the tool bar icons to open document views is covered in Exercise 4, "Icons and Tool Tips" on Page 22.

**Opening Document Views**

Most Geolog applications are MDI (Multiple Document Interface) applications, which means:

- Within the MDI application, documents from other Geolog applications can be created, opened for viewing and/or editing.
  
  For instance, one or more Artist document views can be opened in the Project application, and an Artist picture modified, or a new picture created.

- multiple files can be opened within the MDI application.
  
  For instance, 3 image files can be open simultaneously within the Artist application.

> "Document view" and "window" are interchangeable terms.
To open EXISTING document views of other Geolog applications

In relevant MDI applications (e.g., Well, Project), select Applicationname > View > document type. In this example we are opening an Artist file, logo.cgm within the Project Application.

1. If required, display the Project application window opened in the previous exercise.

2. Take note of the displayed Menus and Tool Bar.

3. Select Project > View > Artist... The File Select dialog box is displayed (see Figure 5). This dialog box is explained in "Using the File Select Dialog Box" on Page 29).

![Figure 5: File Select Dialog Box—opening an Artist file](image-url)
4. Within the Files list, use the Scroll Bar to locate logo.cgm.

5. Click on logo.cgm and click OK to open the file.

The Menus and Tool Bar have changed and now display menus and icons relevant to the open Artist file.

To open NEW document views of other Geolog applications

In relevant MDI applications, select Applicationname > View > New > document type. In this example we are opening a new Xplot view from within Project application.

1. Select Project > View > New > Xplot.

A new, empty crossplot is opened, as shown in Figure 6.

Figure 6: Project Application with Other Applications Document Views Displayed
The Menus and Tool Bar now display menus and tools relevant to the Xplot view, as it is the currently active view.

2. Click on the Document Buttons at the bottom of the screen (see Figure 6), to switch between the Artist view and the Xplot view, noting the changes to the Menus and Tool Bar.

You can open multiple views of the same type. For instance, you can start a new Xplot file and then open an existing Xplot file either by using the previous steps, or by making the Xplot view active (selecting it) and then selecting Viewname > Open or Viewname > New (e.g., Xplot > Open).

3. Leave the Project application and its views open, as you will need them in a subsequent exercise.

To open multiple files within an MDI application

Open multiple views of the same type by selecting Applicationname > Open or Applicationname > New.

1. Display the Artist application you opened in Step 1. of Exercise 1 on Page 9.

   OR, if Artist is not open,

   Display the Geolog Launcher Bar and click on the Artist button.

2. Select Artist > Open.

3. Locate and open the fill_mark.cgm file from the File Open dialog box.

4. Select Artist > Open again.

5. Locate and open marikart.cgm.

Your display should look similar to Figure 7.

![Artist Application - Multiple Files Open and Displayed](image)

**Figure 7: Artist Application - Multiple Files Open and Displayed**

Further details on the various other elements displayed in an application window, and how to manipulate multiple open views in the window, are discussed in "Using Geolog" on Page 27.

7. Leave the Artist application and its views open, as you will need it in a subsequent exercise.
Exercise 3

In this exercise, the views opened in Project in the previous exercise will be saved, closed and then retrieved.

Saving Your Workspace

A workspace consists of the currently open objects within an application, and the currently active view, position, size and minimized/maximized state of those views.

Multiple workspaces can be saved. The Workspace option is available in applications where multiple document types can be opened (e.g., Well or Project).

To save a workspace

1. Go to the Project application.
2. Select **Project > Workspace > Save** to display the File Save As dialog box (see Figure 8).

![Figure 8: File Save As Dialog Box—saving a workspace](www.fanarco.net)
3. In the Selection field, change "workspace.project_workspace" to an appropriate name (e.g., yourname).

    If you delete the extension "project_workspace", and then do not add it, Geolog inserts the extension when it saves the file. Note the extension changes in other applications (e.g., .well_workspace).

4. Click **OK** to save the workspace.

5. Close the Project application by selecting **Project > Exit**. Do not save any changes, if prompted.

To Restore a Workspace

6. Start the Project application.

7. Select **Project > Workspace > Restore** to display the File Open dialog box.

8. Select the required file.

9. Click **OK** to restore the workspace.

    When you exit an application, Geolog does not save a restored workspace that has been modified, so to keep your changes be sure to save the workspace again.

**Exercise 4**

This exercise illustrates how to display Tool Tips, and use icons to open and close views.

**Icons and Tool Tips**

As previously mentioned, menu items and Tool Bar icons change according to the active (selected) view, although icons for some functions, such as opening new or existing views, are available at all times, regardless of the currently selected view. Using the Tool Tips on the icons will aid in identifying the icon and the action that will be performed if that icon is selected.

**Note:** When using Geolog, it is recommended that you use full screen mode to obtain the full benefits of multiple document windows functionality, Tool Bar display, etc.
To display Tool Tips

1. Go to the Project application.

2. Place the mouse over an icon on the Tool Bar - DO NOT CLICK - a Tool Tip for the icon is displayed, along with the keyboard shortcut for that action, if one exists - see Figure 9 on Page 23 for an example.

![Figure 9: Displaying Tool Tips](image)

Using the Open/Create Document View Icons

![Figure 10: Open/Create Document View Icons](image)

<table>
<thead>
<tr>
<th>Open New View:</th>
<th>This menu icon is always available and lists views which can be created within the MDI application (e.g., create a new Artist picture).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Existing View (file):</td>
<td>This menu icon is always available and lists views which can be opened within the MDI application (e.g., open an existing Artist file).</td>
</tr>
</tbody>
</table>

3. Click on the New View and Open View icons, and note the displayed items.

4. Go to the Geolog Launcher Bar and click on the Well icon to open the Well application.
5. Click on the **New View** and **Open View** icons, and note the displayed items.

6. Select **Well > Exit** to close the Well application.

**Using the New application and Open Existing application Icons**

In applications which permit multiple open views, or only a single view, but not multiple document types, only New and Open icons are displayed.

For example, in Artist, you can open multiple Artist files or create multiple new pictures but you cannot open a crossplot. In Section, only one section view can be open at one time.

7. Go to the Artist application.

8. Click on the **New** and **Open** icons.

Throughout the tutorials, when an icon or icons are displayed to the left of the instruction, such as

![Project > View > New > Mapsheet](image)

you can select the applicable icon, rather than the menu items, to perform the same action.

**Exercise 5**

In this exercise, you will close all open views in the Project application.

**Closing Document Views**

There are several methods to close document views.

1. To select the document view to be closed, click on its Title Bar, or its document button as shown in Figure 11.
2. Using Figure 11 as a guide, do any of the following to close the open document views, xplot and artist:

- Click on the Close icon. The active view is closed (in this example, xplot would be closed).
- Select Viewname > Close where Viewname is the name of the currently active (selected) view. In Figure 11, the currently active view is xplot, so Xplot > Close is selected.
- Click on one of the two Window Close icons of the document view. "Working with Multiple Document Views" on Page 27 explains how to minimize/maximize views.

Figure 11: Methods for Closing Document Views
Only the bottom icon is displayed if the view has been maximized.

— Select Applicationname > View > Close All (where Applicationname is the MDI application, not the document view). In this example, Project > View > Close All is selected.

In applications where only a single file, or multiple files but not multiple files of other document types, may be opened, the menu selections are Applicationname > Close or Applicationname > Close All (e.g., Section > Close or Artist > Close All).

**Exercise 6**

In this exercise, you will close all open Geolog applications.

**Closing Applications**

To close an application, select the application name from the menu and then select Exit. For example:

- Project > Exit

**Closing Geolog**

To exit Geolog, on the Launcher Bar select Project > Exit.
Step 3: Using Geolog

Procedure

This step introduces the various Geolog window components and terminology. You will:

- Work with multiple document views to become familiar with the Geolog window components.

- Learn to use the Geolog dialog boxes by using the:
  - File select dialog box, which is displayed whenever a file is to be saved, opened, printed, etc.
  - Properties dialog box, which is used to format and modify all Geolog displays.

- Become familiar with the commonly used Appearance palette dialog box.

Exercise 1

Working with Multiple Document Views

1. To open Geolog select Start > All Programs > Geolog6 > Geolog6.

2. From the Geolog Launcher Bar, open the Well application. All menus except Well and Help are "grayed out" (see Figure 12).
To use the Well tools to display and process data, you must specify the data to be used by opening a well.

You do not need to specify a dataset to create templates for layouts, crossplots, etc.

3. Select **Well > Open**... to display the Well Select dialog box (see Figure 13).
4. Select the **ELECTRA** well.

5. Click **OK**.

**Note:** The menu items are available and no longer "grayed out", because data is now available to process.

---

**Using the File Select Dialog Box**

A File Select dialog box is displayed whenever a file is to be saved, opened, printed, etc. The name displayed in the Title bar of the dialog box changes according to the function being performed. For instance, if saving a file, the Title bar displays "File Save As" and when opening a file, "File Open".

6. Select **Well > View > Xplot...** to display the File Open dialog box (see Figure 14).
Following is a brief explanation of each section in the File Select dialog box. Your instructor will provide further assistance in using the options.

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Searchlist</td>
<td>All directories in this section are restricted to the files found using the directories which are search listed by Geolog, according to the environment variable MINSL. The top directory is selected by default (in this example, ^LAYOUTS) and lists all files found in all search listed directories.</td>
</tr>
<tr>
<td>Recent</td>
<td>A list of all directories that have been used during the current working session (e.g., until Well is closed).</td>
</tr>
<tr>
<td>Root</td>
<td>A list of all directories at your site.</td>
</tr>
</tbody>
</table>
7. From the release directory, locate and open `rho_nphi_gr.xplot`.

8. Select **Well > View > Use Rulers** to display Rulers in any views subsequently opened.

9. Select **Well > View > Artist...**

10. Locate and open `logo.cgm`.

11. Select **Well > View > Layout...**

12. Locate and open `exercise.layout`.

Your display should look similar to Figure 15.
Figure 15 and the table below identify and briefly describe the common elements found on Geolog’s windows and document views. Your instructor will guide you through selecting and using these various components.

<table>
<thead>
<tr>
<th>Title Bar</th>
<th>Menu Bar</th>
<th>Tool Bar</th>
<th>Document Views</th>
<th>Resize Bar</th>
<th>Status Bar</th>
<th>Rulers</th>
<th>Display Bar</th>
<th>Scroll Bar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identifies the application you are using, and, where applicable, the currently open project, specified well(s) and/or section(s), specified default set, and currently active view.</td>
<td>The Menu bar displayed is VIEW SPECIFIC, in other words, the menus displayed are relevant to the currently active view. In this example, a layout is the active view.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Tool Bar
A set of icons for frequently used menu commands. Like the Menu Bar, the Tool Bar is VIEW SPECIFIC. You may need to maximize the window to see all the icons on the Tool Bar, and some Tool Bars contain more icons than can be displayed, so you will need to use the Tool Bar Dividers.

Tool Bar Dividers on the Tool Bar are used to hide/display sets of icons. The Dividers are TOGGLE icons, click on a Divider once and the icons to the right are hidden, click on the Divider again and they are redisplayed.

### Document Views
Use the Document buttons and View icons on the Display Bar (see Page 34) to manage multiple open views.

The menu items, *Applicationname* > View > Save All and *Applicationname* > View > Close All are also useful tools.

### Rulers
According to the scale selected, metric or imperial rulers can be displayed on the X and Y axes of graphical views. The Units identified is an indicator showing the current ruler units. The units will change according to the display (e.g., from IN to FT or CM to DM) as a larger drawing is overviewed.

By default, Rulers are not displayed in a view, except in the Artist application.

Select the toggle function *Applicationname* > View > Use Rulers BEFORE creating a new, or opening an existing, view in order to display the rulers.

**Note:** Selecting this function after a view has been opened will have no effect on that view.

The default for your site can be changed by the Systems Administrator if you prefer to always have rulers displayed for all views.

### Resize Bar
Some views, such as Layouts, have header and/or footer sections. Use the Resize bar to change the size of the sections.
Scroll Bars

Vertical and horizontal scroll bars are displayed when all the information does not fit within the window. The Scroll bars can also be used to "refresh" the view if information is being displayed incorrectly.

Mouse Pointer and Crosshairs

Some graphical views (e.g., layouts, crossplots) have crosshairs attached to the mouse pointer to provide easier identification of the pointer position within the work area. Use in conjunction with the Position information displayed on the Status Bar (see Page 35).

Display Bar

The Quick Access icons are toggle buttons for:

- Menu List (see Page 36) icon
- Appearance Palette (see Page 42) and 3D View icons which are floating dialog boxes.
  
  Select the Hide button in dialog boxes (where available) to iconize floating dialog boxes to this area.

Click on a Document button to make that document view (window) active.

When there are numerous documents open, there may be insufficient room to display all the Document buttons. Use the Scroll buttons to locate the required Document button.

View icons from left to right are:

- Tiling Order: Click to open the Tiling Order dialog box and specify a format to concurrently view all open Document views on the screen.
- Snap to Grid: Click to adjust the position of the document window(s). The position of the window snaps to the nearest grid lines. If you have "lost" a window, select its Document button and then click on the Snap to Grid icon to redisplay it, or use the Maximize icon (see below).
- Minimize: Minimize the currently active window.
- Maximize: Toggle between Maximizing and Restoring the currently active window. Double clicking the Title bar will also maximize a window.
- Close: Click to close the currently active window.
**Status Bar**

- **Position first pin**
- **More Info Icon and Message Area**
- **More Info icon and Position Information**

### Examples of Status / Prompt Areas

- **Ready**
- **Opening layout: /layouts/exercise.layout**
- **1561.417,79.5**

### Message Area

- **Feedback**
- **Opening ELECTRA/REFERENCE DEPON**
- **Opening split C:\...**
- **Opening ELECTRA/MODEL**
- **Opening ELECTRA/MODEL:**
- **Opening ELECTRA/MODEL:**
- **Opening ELECTRA/MODEL:**
- **Opening ELECTRA/MODEL:**

### Position Area

- **DEPTH 1561.417 FEET**
- **GR 79.548 GAPI**

**Status / Prompt Area**

Displays the current status of the application. Also displays prompts to guide you when performing actions such as drawing an Artist object.

**Message Area**

Displays the last system message.

Click on the More Info icon to open the Feedback window to view a detailed, list of historical messages.
Position Information | Displays the current location of the mouse pointer and crosshairs.
---|---
Click on the More Info icon to display detailed position information. Information is displayed according to the type of document:

**Mapsheet**: at the X and Y location.

**Layout**: at the actual positions in relevant units, for example metres, ohmm. If there are no logs selected in the track, the Position dialog box displays the Reference datum value of the position of the crosshairs, as well as the log values at that position. If there is a log or logs selected in a track, only the values for the Reference datum and the selected log(s) are displayed.

**Crossplot** (Xplot): at the X and Y axes.

**Histogram** (Frequency): at the log value, percentile and cumulative value of the histogram.

**3D image** (Image3D): X- and YOFFSET, TVD, and if the mouse is on the image, azimuth and depth.

**Wellpath**: on the plan, at the intersection of the X- and YOFFSET. On the section, at the intersection of the selected (using the Properties dialog box) Reference and Section.

**Picture** (Artist): at the X and Y position.

---

### Exercise 2

#### Menu List

Geolog’s Menu List is a graphical "tree" or list view of the application menus only. For instance, when in Well, the Menu List displays the General, Petrophysics, Geology and Geophysics menus. Regardless of whether or not, a document view such as layout, is currently open and active, these application menus still display when the menu list icon is selected (see Figure 16 for an example).

To display the Menu List

1. Click on the **Menu List** icon, in the Quick Access area of the Display Bar (see Page 34).

The application menus are displayed on the right side of the window (see Figure 16).
You can navigate the Menu List using the mouse or keyboard:

<table>
<thead>
<tr>
<th>Activity</th>
<th>Mouse Operation</th>
<th>Keyboard Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>To expand a menu</td>
<td>Click on its Plus + sign OR double click on its menu name.</td>
<td>Select the menu and press the right arrow key.</td>
</tr>
<tr>
<td>To collapse a menu</td>
<td>Click on its Minus - sign OR double click on its menu name.</td>
<td>Select the menu and press the left arrow key.</td>
</tr>
<tr>
<td>To expand or collapse all items beneath a menu</td>
<td>RIGHT click on the menu name and select <strong>Expand Branch</strong> or <strong>Collapse Branch</strong>.</td>
<td>-</td>
</tr>
<tr>
<td>To expand or collapse ALL menus</td>
<td>RIGHT click on <strong>Menu List</strong> and select <strong>Expand Branch</strong> or <strong>Collapse Branch</strong> (see Figure 17 for an example)</td>
<td>-</td>
</tr>
</tbody>
</table>
Warning: Geophysics and NMR are not multiwell applications, therefore, if you have multiple wells open do not use these processes on the Menu List, as results may not be correct.

2. Right click on Geophysics and select **Expand Branch**.

3. Within Utilities > Log Edit, double click on **Fill Missings** to invoke that menu item.

4. Click the **Close** icon, to close the Fill Missings module.
Properties Dialog Box

The Properties dialog box is used in all graphical Geolog applications, except Section, to format and modify the display. In Section, separate dialog boxes are used for modifying and formatting. In the Loglan application, the Properties dialog box is used to specify program details.

To open the Properties dialog box use one of the following methods:

- click on the Properties icon, or
- double click within the working area, or
- select Edit > Properties.

1. Close all open views in the Well application EXCEPT the layout (exercise.layout) view.

2. Select Edit > Properties to open the Properties dialog box (see Figure 19).
when a Properties dialog box is open you can still select most display tools to adjust the active view, for example, you can use the scroll bars, resize buttons, and most of the icons on the Display bar or Status bar, such as the More Information icon. However, no other functions are available, nor can you use the display tools when other dialog boxes are open.

Figure 19 and the table below identify and briefly describe the common elements found in Geolog’s dialog boxes. The instructor will guide you through selecting and using these various components.

<table>
<thead>
<tr>
<th>Section Label / Section Border</th>
<th>The Section label and border identify all options available for that section.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section Buttons</td>
<td>If available, use the Section buttons to modify the options within the Section.</td>
</tr>
<tr>
<td></td>
<td>For example, click on the track name and then click <strong>Delete</strong> to remove a track from the list and the layout.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>An area displaying the current selection(s). For instance, all tracks used in a layout, the log displayed in the track, or the appearance of the displayed log.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section Action Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>To identify an Action button for a Section, hover the mouse over the button to display the Tool Tip.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Position Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an item and then click on a Position button to move the item.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Dialog Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identified with an ellipsis (...) after the label on the button. When selected, another dialog box is displayed. The Border... button is found on all Properties dialog boxes and is used to format the appearance of the presentation sheet (area surrounding the working area).</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Checkbox</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click to toggle the function on or off.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tabs</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on a tab to display formatting functions specific to the label on the tab.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Appearance Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A special field that, when selected, displays the Appearance Palette, which is explained in further detail in Exercise 4, &quot;Appearance Palette&quot; on Page 42.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Radio Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A series of toggle buttons indicating several options available. Click to select an option; click another checkbox to turn off. Where more than one option can be selected, click the button again to turn off.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Action Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>These action buttons are found on a typical Properties dialog box.</td>
<td><img src="image" alt="Action Buttons" /></td>
</tr>
</tbody>
</table>

- **OK**: Apply the changes made in the dialog box and close the dialog box.
- **Apply**: Apply the changes made in the dialog box but leave the dialog box open.
- **Defaults**: Layout Properties dialog box only; use to restore the defaults for the log. Click on this button to replace any Units, Left/Right and Scale values entered with the default values.
- **Border...**: Click to open another dialog box to format the presentation area of the display.
- **Cancel**: Cancel the changes made in the dialog box and close the dialog box. If **Apply** has previously been selected, those changes are not cancelled.
- **Help**: Display help on the dialog box and any related topics.
Appearance Palette

The Appearance palette is used extensively throughout Geolog to format the appearance of object attributes, such as color, line type, text style and fill patterns. It also provides access to a standard set of markers such as well and point symbols.

To format the appearance of objects

• Click in an Appearance field in a dialog box to display the Appearance palette

OR

• Select an object and then select View > Appearance.

The following is an example of formatting using an Appearance field:

1. Select the Wireline track in the Edit list (see Figure 20) in the Properties dialog box, for the layout used in the previous exercise.

2. Click on the Track tab.
3. Click on the GR log in the Logs field, to select the log to be formatted.

4. Click in the Appearance field for the Wireline Log, to display the Appearance palette (see Figure 21).
5. Click on the Blue box on the Color tab.

6. Click **Apply** in the Properties dialog box.

   Changes are made to the object as soon as you:

   — click **Apply** or **OK** when using an Appearance field in a dialog box, or
   — if an object is selected, when the required appearance feature is selected.

7. Use the scroll bar or expand the dialog box to display a larger selection, as shown in Figure 22. The resized dialog box remains at that size until either it is resized again, or the application (e.g., Well or Artist) is closed.
Your instructor will provide further information and assistance with using the Appearance palette. You can also find detailed information by clicking on the Help button on the Appearance palette to display the Geolog online help.

**Figure 22: Resizing the Appearance Palette Dialog Box**
Step 4: Help

Procedure

This step explains how to access the online help documentation provided with Geolog. You will:

- Start Help and navigate through various areas.

Accessing Online Help

Online help files are in PDF format. To access these files, you need Adobe Reader (provided on the Geolog installation disk) installed on your computer.

Within Geolog

To access the online help select Help from any Menu Bar; a list of relevant help items is displayed:

Select Help from the Menu Bar to display various help topics

Figure 23: Menu Bar Help
Accessing Online Help via the Main Menu

1. Click Help on the Menu bar.

2. To access all Paradigm products, select **Main Menu**...

3. To access the Geolog help topics, click on Geolog (see Figure 24).

![Online Help Main Menu for Geolog](image)

Click on topics to display further information.

**Figure 24: Online Help Main Menu for Geolog**
Accessing Specific Application Online Help

1. Click Help on the Menu bar.

2. Select On Name to display help on that topic or application (e.g., On Well).

The online help Table of Contents for the selected application or topic is displayed, see Figure 25.

Displaying the Software Version Information

Select Version... to display information about the software.
Other Methods of Accessing the Online Help

- Click the Help icon to directly access help on the currently open application.
- Click on the Help button within a dialog box to display help on that dialog box and other related topics.
- Press F1 when performing a function, such as inserting a pin, to display help on that function (command). There is an item on the menu, On Command... F1 but it may be difficult to select the menu while performing a function.

Accessing Online Help From Unix

To access online help directly from a UNIX shell:

1. Run Acrobat Reader by typing `acroread` at the system prompt.
2. Select File > Open and specify the following path:

   `<geolog6>/doc/pdf/geolog_main_menu.pdf`

   Where `<geolog6>` is the directory in which the Geolog software has been installed).

Help on Help

To find out more about using online help and Adobe Acrobat Reader, select Using Help on the Geolog Main Menu.

Exercise 1

1. Select Help > Main Menu... from the Well Tool Bar.
2. Click on Geolog.
3. Click on the Application Windows tab.
4. Click on Well.

Text in a bright blue color indicates a link. Click on this text to view more information.

Use the following buttons to navigate the online help documentation:
Exercise 2

Searching All Geolog Online Help

One of the most useful tools in the online help is the Acrobat Index. This index is different from the Geolog index and is accessed when you perform a search using the Search button on the Main Menu or when you select Edit > Search in Adobe Reader. Each Geolog user must set Reader to correctly access the index file before a search can be performed.

Instructions for both Unix and Windows are included in this tutorial.

UNIX - To permanently attach an index in Reader

1. Go to the Geolog Main Menu (see Figure 24 on Page 47).
2. Click Search in the top right corner, to open the Adobe Acrobat Search dialog box.
3. Click on **Indexes...** to open the Index Selection dialog box.

4. Click **Add...**

5. Locate and select the `geologX.X.pdx` file (where X.X is the current version of Geolog) found in the `software release/doc/pdf` directory (your instructor can assist with the correct location).

6. Click on **Open**. Your dialog box should now look like Figure 28.
7. If it exists, deselect (remove the tick) from the "Acrobat xxx Online Guides" (where xxx is the version of Acrobat Reader you are using). Reselect when you wish to perform a search for information on Acrobat Reader itself.

8. If other Geolog Index versions exist, select and click **Remove**.

9. Click **OK**.

10. To test, enter search criteria in the Search dialog box (e.g., **Z Posting**).

11. Click **Search**.

12. A list of matching entries is displayed. Double click on the entries to display the information.

![Index Selection Dialog Box with Geolog Index specified](image)

*Figure 28: Index Selection Dialog Box with Geolog Index specified*

Use the Search icons in Reader to navigate the search results.
WINDOWS - To permanently attach an index in Reader

**Note**

If you always start the Geolog help files from the Main Menu (see Figure 24 on Page 47), or select the Main Menu before performing a search, you do not need to attach the index, as it is automatically attached for you *BUT this is temporary (for the current working session only), and you must always ensure to view the Main Menu before performing a search in order for the index to be automatically attached*. See Figure 30 for an example.

To permanently attach an index in Reader

1. Go to the Geolog Main Menu (see Figure 24 on Page 47).
2. Click **Search** in the top right corner to open the Search PDF pane (see Figure 30).
3. Select **Use Advanced Search Options** (see Figure 30).
4. In the Look In field, click on the **Dropdown List** button and select "Select Index..." to display the Index Selection dialog box.
5. Click **Add** and locate and select the `geologX.X.pdx` file (where X.X is the current version of Geolog) found in the `software release/doc/pdf` directory (your instructor can assist with the correct location).

6. Click on **Open**. Your dialog box should look like Figure 28.

7. If other Geolog Index versions exist, select, and click **Remove**.

8. Click **OK**.

9. To test, enter search criteria (e.g., **Z Posting**) in the Search field (at the top of the Search PDF pane).

10. Click **Search**.
11. A list of matching entries is displayed. Click on the entries to display the information.

Select **Edit > Preferences**, click on Page Display and select "Custom Resolution: 72 pixels/inch" to set the view to a smaller default view.

To specify the Advanced Search Options for the default, click on Search and select "Always use advanced search options."
Step 5: Project Management

Procedure

This step explains the structure of Geolog projects, and how to modify projects. You will learn how to:

- Create a project
- Open a project
- Deregister a project

Project File Structure

A Geolog project groups related wells together so they can be managed and analyzed effectively. A project can also be seen as a directory that contains log data, wells, plots, functions, reports, layouts, specifications and sections. A number of current projects can be grouped as working projects, with each project typically identified using names of basins, fields, authority permits, etc.

When a new project is created, a project directory and the following subdirectories under the project directory are created:

<table>
<thead>
<tr>
<th>DIRECTORY</th>
<th>TYPES OF FILES</th>
</tr>
</thead>
<tbody>
<tr>
<td>data</td>
<td>data to load, unloaded well data, tape devices</td>
</tr>
<tr>
<td>layouts</td>
<td>display specifications for data, xplots, frequencies</td>
</tr>
<tr>
<td>loglan</td>
<td>loglan programs and executables, modules</td>
</tr>
<tr>
<td>plots</td>
<td>pictures (CGM and other formats), plotter devices</td>
</tr>
<tr>
<td>reports</td>
<td>load, well, regression, etc. reports</td>
</tr>
<tr>
<td>specs</td>
<td>load specifications, application parameters, etc.</td>
</tr>
</tbody>
</table>

Other directories for the project are created by Geolog, as required (e.g., when you load data, or create and save a cross section):

<table>
<thead>
<tr>
<th>DIRECTORY</th>
<th>TYPES OF FILES</th>
</tr>
</thead>
<tbody>
<tr>
<td>functions</td>
<td>curves, macros, polygons</td>
</tr>
<tr>
<td>sections</td>
<td>section display specifications</td>
</tr>
<tr>
<td>wells</td>
<td>loaded well data</td>
</tr>
</tbody>
</table>
The following directories may be created, if required, but are generally used for the site project.

<table>
<thead>
<tr>
<th>DIRECTORY</th>
<th>TYPES OF FILES</th>
</tr>
</thead>
<tbody>
<tr>
<td>app-defaults</td>
<td>menus</td>
</tr>
<tr>
<td>bin</td>
<td>executables, environment specifications</td>
</tr>
<tr>
<td>graphics</td>
<td>patterns, fills, markers</td>
</tr>
</tbody>
</table>

New projects are created from the Geolog Launcher Bar. Existing projects can be opened from the Unix prompt or the Geolog Launcher Bar.

**Exercise 1**

**Creating New Projects**

**To create a new project**

If you have just started Geolog:
- Select the **Cancel** button in the Project Select dialog box. The New Project dialog box is displayed.

OR

If Geolog is already running:
1. From the Geolog Launcher Bar, select **Project > New** to display the New Project dialog box.

![Figure 35: New Project Dialog Box](www.fanarco.net)
2. Click the **Private** radio button.

3. In the Name field, enter `mynameproj` where `myname` is your first name (e.g., `johndproj`).

4. Enter a description, if required.

5. In the Directory field, enter the explicit directory path to this new project (e.g., `/usr/projects/johnproj` or `d:/projects/johnproj`). Your Instructor will guide you as to the correct path to use.

6. Leave the Type and Host as displayed.

7. In the Dataset field, enter the same path and project name as in the Directory field. See Dataset in the table below for further information.

8. Click **OK** to create the project.

The table below explains, in detail, the components of the Project New dialog box.

<table>
<thead>
<tr>
<th>SECTION</th>
<th>FIELD / BUTTON</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geolog Project</td>
<td>Public/Private</td>
<td>Click the <strong>Public</strong> or <strong>Private</strong> radio button. Public projects are projects that are available to all users. Private projects are projects that are restricted to the owner of the project, and, if required, any other users specified by the Systems Administrator.</td>
</tr>
<tr>
<td>Name</td>
<td></td>
<td>Enter the name of the project. Names should be ≤ 32 characters; do <strong>not</strong> use spaces; it is recommended that you use only A-Z, 0-9, underscore (_) and dash (-) characters.</td>
</tr>
<tr>
<td>Description</td>
<td></td>
<td>Optional.</td>
</tr>
<tr>
<td>Directory</td>
<td></td>
<td>Enter the path to the application data (e.g., layouts, specifications, plots) but not the database files. OR Click on the <strong>Directory</strong> button and use the File Selector to locate the required path.</td>
</tr>
<tr>
<td>Well Database</td>
<td>Type</td>
<td>Click on the dropdown list and select the required database type. This field defaults to a EPOSDATA 3.0 database.</td>
</tr>
<tr>
<td></td>
<td>Host</td>
<td>Type the host name of the machine on which the database files reside. OR Click on the dropdown list and select a host.</td>
</tr>
</tbody>
</table>
See Creating New Projects, in the Environment online documentation, for further information and examples of project creation in complex environments.

See Starting Geolog in a Default Project, in the Environment online documentation for further information on specifying the project name before starting Geolog.

## Exercise 2

### Opening Projects

The new project name and description, as well as all other data from the New Project dialog box, are stored in the pns.<pns host name>.projects file in the /PNS3/config directory. This file is used by Geolog to display all projects available to the user, based upon filtering criteria, in the Project Select dialog box.

All projects for your site should be listed for selection but note that directory and file read/write permissions will affect your ability to open and/or make changes to projects.
To open a project

If Geolog is NOT running:
1. Start Geolog. If a default project has not been specified, the Project Select dialog box is displayed (see Figure 36).

   See "Starting Geolog in a Default Project" in the Environment online help documentation for information regarding setting environment variables which enable a default project to be set prior to starting Geolog. This would ensure that when Geolog is started, the default project is automatically opened.

If Geolog is already running:
1. Select **Project > Open** on the Launcher Bar to open the Project Select dialog box (see Figure 36).
2. Use the scroll bar to locate the required project

OR

In the Filter section:

• Click the **Type** dropdown button and select the required database type.

• Click the **Host** dropdown button and select the required host.

• Click the **Owner** dropdown button and select the required permission type.

• If required, enter a wildcard to facilitate searching for the required project;
  
  Click on the **Action** icon to display those projects matching the criteria specified in all the fields in the Filter section.

  Note you need only click the **Action** icon if criteria has been entered in the Name Wildcard field.

3. If required, display details of a project by clicking on the name of the project in the Selection field and then toggling on the **More Info** icon next to the Desc field (see Figure 37).
4. In the Selection section:

- Double click on the required name in the list of projects to open the project.

  OR

- Click once on the name of the project required and then click OK to open the project.

**Removing / Changing Projects**

Before a project is removed or renamed it must first have its entry removed from the project registry. See “Deregistering Projects” below for more information.

The individual with the required permissions, usually the System or Project Administrator, can remove/change projects by renaming the project directory, or deleting/archiving the project directory and its subdirectories (see "Project File Structure" on Page 58).
Deregistering Projects

Deregistering projects simply removes the project from the project register (the list of projects displayed in the Open Project dialog box). **It does not remove any data or directories.** A user can deregister projects over which they have ownership.

1. From the Geolog Launcher Bar, select **Project > Deregister...** to display the Project Select dialog box.

2. Select Mine from the Owner dropdown list, then select the required project to display the Deregister Project dialog box (see Figure 38).

3. Click **OK** to confirm the process.

**Figure 38: Deregister Project Dialog Box**